smitty Devices - Install/Configure Devices Added After IPLJust keep the menu item
INPUT device / directory for software [none]unless the new device needs extra drivers (for disks almost never).
vgmisc
,
does not yet exist, create it as follows:
smitty System Storage Management - Logical Volume Manager - Volume Groups - Add a Volume Group
Original
, Big
or Scalable
.
Original
corresponds to the VGs known from AIX<=5.2
and usually suffices.
For special requirements matched by the other two,
refer to IBM documentation for details.
VOLUME GROUP name [vgmisc] Physical partition SIZE in megabytes + * PHYSICAL VOLUME names [] +The entry
Physical partition SIZE in megabytes
specifies the smallest increment by which disk space is allocated to logical volumes.
Original
VG can have up to 1016 "Physical partitions" (PPs)
which have to be chosen large enough so that the whole disk can be covered.
Here's a quick lookup of PP size vs disk size:
Disk | PP size |
---|---|
36GB | 32MB |
146GB | 256MB |
300GB | 512MB |
450GB | 512MB |
600GB | 1024MB |
For the PHYSICAL VOLUME names
you'll have the choice
among all active disks not yet assigned to a VG.
If you plan disk mirroring, you may choose both or just one,
and add the second one later.
lvscratch
:
smitty System Storage Management - Logical Volume Manager - Logical Volumes - Add a Logical Volume VOLUME GROUP name [vgmisc]Most default settings can be left unchanged, except:
Logical volume NAME [lvscratch] * Number of LOGICAL PARTITIONS [128] # Logical volume TYPE [jfs] + MAXIMUM NUMBER of LOGICAL PARTITIONS [512] #This defines a logical volume of 64GB maximum and 16GB actual size, given a physical partition size of 128MB.
Logical volume NAME [lvscratch] * Number of LOGICAL PARTITIONS [1] # Logical volume TYPE [jfs2] + RANGE of physical volumes minimum + Number of COPIES of each logical 2 + partition MAXIMUM NUMBER of LOGICAL PARTITIONS [2048] #
Number of LOGICAL PARTITIONS
is set to the
minimum value, corresponding to a single physical partition (PP).
It can be increased conveniently later via the file system size definition.
Number of COPIES
corresponds to the actual number of disks
in the VG. Set it to 1
, if only one disk is used.
MAXIMUM NUMBER of LOGICAL PARTITIONS
is an educated guess
covering the whole disk. It can be increased later, if needed.
fsscratch
:
jfs
: smitty System Storage Management - File Systems - Add File Systems - JFS - Add a JFS on a Previously Defined LV - Add a Large File Enabled Journaled File System * LOGICAL VOLUME name lvscratch * MOUNT POINT [/fsscratch] Mount AUTOMATICALLY at system restart? yes + Start Disk Accounting? no +The choice
Number of bytes per inode 4096 + Allocation Group Size (MBytes) 64defines a filesystem of max 64GB size.
Number of bytes per inode 16384 + Allocation Group Size (MBytes) 8allows a size of 256GB.
jfs2
:
smitty System Storage Management - File Systems - Add / Change / Show / Delete File Systems - Enhanced Journaled File Systems - Add an Enhanced Journaled File System on a Previously Defined Logical VolumeDefault settings can be left unchanged, except:
* LOGICAL VOLUME name lvscratch + * MOUNT POINT [/fsscratch] Mount AUTOMATICALLY at system restart? yes + ENABLE Quota Management? all +
smitty System Storage Management - File Systems - Mount a File Systems FILE SYSTEM name [/dev/lvscratch] + DIRECTORY over which to mount [/fsscratch] + # or on the command line: /usr/sbin/mount /dev/lvscratch /fsscratch
smitty System Storage Management - File Systems - Add / Change / Show / Delete File Systems - [Enhanced] Journaled File Systems - Change / Show Characteristics of an [Enhanced] Journaled File System File system name /fsscratch NEW mount point [/fsscratch] SIZE of file system Unit Size Gigabytes + Number of units [128] #
chvg -Q'n' vgmiscotherwise both disks would be needed to keep the VG online, which is not what you want in case just one disk fails.
chmod g+sw /fsscratch chown ourgroup:ourgroup /fsscratch
/tmp
)
adapt the /etc/skulker
script or use some equivalent
(scavenger
)
and place a respective entry in the crontab
file, for example:
crontab -e 0 3 * * * /usr/sbin/skulker # or 0 3 * * * /opt/bin/scavenger -t+1 /fsscratch >/dev/null
smitty System Storage Management - File Systems - Change File Systems - Network File System (NFS) - Add a Directory to Exports ListYou may just accept the default settings, except:
* Pathname of directory to export [/fsscratch] / * Security method 1 Hosts & netgroups allowed client access [] Hosts allowed root access []
netgroups
are defined via NIS and conveniently
combine groups of hosts allowed client access under a unique name.
If nothing is specified, all hosts are allowed, except the root
user,
which has to be enabled separately.
root
access.
automount
:
/etc/auto.s
bio -rw,bg,soft,intr,retry=10 fileserver:/fsscratch/bio
rdist
:
rdist -f /bio/local/../autofs.distfilewill distribute the configuration files over all machines defined in the
distfile
.
umount -f /mount_point_for_fsscratchIf, as usual, this can't be accomplished because somebody is using the filesystem, use
fuser /mount_point_for_fsscratch # or: lsofto discover and
kill -9
the offending processes.
fuser -kxuc /mount_point_for_fsscratchkills everything associated with
/mount_point_for_fsscratch
.
automount
daemon on all clients, for example:
umount -f /mount_point_for_fsscratch; stopsrc -s automountd; startsrc -s automountdor, if this doesn't work:
umount -f /mount_point_for_fsscratch; stopsrc -s automountd; /usr/sbin/automount -m -v -f /etc/auto_master