ESC
to enable admin menu, insert Install CD and
boot P3 # for C8000: boot path, selected via console menu boot scsi.3 # for older models: assume CD-ROM with ID=3accept defaults for installation. Skip network configuration for later. For 10.20 systems, VUE may be selected as GUI, if desired. On prompt, take the chance to adapt filesystem sizes, e.g.:
swap 192MB # 160MB ? /opt 832MB # for disk resident Instant Information +64MB /usr 384MB /var 416MB /tmp 64MB
/opt 1152MB # for disk resident Instant Information, native compilers etc. /usr 768MB /var 512MB /tmp 128MB
shutdown # single user mode, root login umount /usr lvextend -L 128 /dev/vg00/lvol4 # /tmp 128MB extendfs /dev/vg00/lvol4 lvextend -L 768 /dev/vg00/lvol7 # /usr 768MB extendfs /dev/vg00/lvol7 lvextend -L 128 /dev/vg00/lvol5 # /home 500MB, if local user filesystems extendfs /dev/vg00/lvol5 lvextend -L 896 /dev/vg00/lvol6 # /opt 896MB, if local dynatext extendfs /dev/vg00/lvol6 init 4 # back to multi user mode
mount -r /dev/dsk/c0t3d0 /cdrom # CD-ROM at SCSI ID=3 swinstall -iwhen prompted select
/cdrom/QPK110
(HP-UX 11.0)
/cdrom/700QPK1020
(HP-UX 10.20)
swconfig \*Note the backslash. Ensure that
/etc/fstab
is clean, i.e. does not contain references to non-existing devices.
mount -o cdcase /dev/dsk/c0t3d0 /cdrom # CD-ROM at SCSI ID=3, lowercase handling /cdrom/uxinstal/setup.sh /cdrom # prepare depot /usr/sbin/swinstall -s /var/spool/sw/InstInfo # do it (might need network configured !) /cdrom/uxinstal/cleanup.sh # cleanup depot # installation on disk: mkdir /opt/hpii_books /cdrom/uxinstal/cp2disk.sh /cdrom /opt/hpii_books # takes ages, be patient ! # update information, important ! /cdrom/uxinstal/newdisk.sh /opt/hpii_books /opt/dynatext export PATH=/opt/dynatext/bin:$PATH # put this in the appropriate .profile
PHKL_29243, PHSS_37516, PHSS_37516
to enable Firefox,
/etc/inetd.conf
disable all unnecessary services.
If the machine should offer boot services,
bootps
and tftp
must be enabled.
chmod o-x /usr/bin/ypcat
/etc/set_parms hostnameand set IP address with
/etc/set_parms ip_addressIf necessary, change LAN config with
SAM
/etc/set_parms addl_netwrkto specify network mask (255.255.255.0) and Gateway address (192.168.1.1).
/etc/resolv.conf
should look like
domain gsi.de nameserver 127.0.0.1 # localhost nameserver 140.181.98.80 # machine itself
domain localdomain # some dummy domain name nameserver 192.168.1.1 # router
/etc/nsswitch.conf
hosts: files[NOTFOUND=continue UNAVAIL=continue] dns [NOTFOUND=continue UNAVAIL=continue TRYAGAIN=continue] nisspecifies name resolution in the order
/etc/hosts
, DNS nameserver, NIS.
(leave out the nis
entry if NIS won't be active).
More information with
man switch
/etc/hosts
, e.g.:
127.0.0.1 localhost loopback 192.168.1.1 vigor 192.168.1.42 rs6kf
tar.Z
) opt/TWWfsw
.
This can be redirected prior to installation to the local directory
with
mkdir opt ln -s ../ opt/TWWfsw
/opt/
/opt/
PATH
and MANPATH
entries should be made
in central startup scripts, e.g. /opt/bin/.profile
.
Software installation on NFS-mounted filesystems:
modify /var/adm/sw/defaults
to contain the lines
swconfig.write_remote_files = true swcopy.write_remote_files = true swinstall.write_remote_files = true swpackage.write_remote_files = true swremove.write_remote_files = true swinstall.enforce_dependencies=falseA complete list of options can be found in
/usr/lib/sw/sys.defaults