The product documentation library is also available:
http://www.rs6000.ibm.com/resource/aix_resource/Pubs/index.html
There are two ways to determine how much memory should be be made available as communications memory buffers (mbufs). This amount of memory is defined using the maximum number, or maxmbuf.
This method counts the total number of communications adapters in the system (whether being used for SNA or not), and then multiplies this number by 4096. The result is used as the setting for maxmbuf.
For example, if there are two token ring adapters that are being used for SNA and two Ethernet adapters that are being used for TCP/IP, the calculation would be 4 adapters multiplied by 4096, or 16384. 16384 would be the number used for maxmbuf.
SNA generally requires more memory for buffers than other applications. With the larger memory sizes that have become available, SNA will usually operate efficiently if the maxmbuf parameter is set to a number equal to 25% of real memory. In most circumstances, any number larger than 64MB (65536) will not yield any appreciable benefit.
For example, if there is 128Mb of real memory on the machine, set the maxmbuf parameter to 32Mb (32768). If there is 512Mb of memory, set maxmbuf to the recommended maximum of 64Mb (65536).
If SNA_SRF errors are being logged in the system error log, this parameter should be checked.
lsattr -El sys0 |grep maxmbufTo change this parameter, enter the following:
chdev -l sys0 -a maxmbuf=new_valueFor example, to set maxmbuf to its maximum value of 64MB, enter the following:
chdev -l sys0 -a maxmbuf=65536NOTE: On AIX 4.2 and AIX 4.3, the default for maxmbuf is 0. This value is known to cause problems with SNA. Please set maxmbuf to any value other than 0.
For an SDLC connection, the Receive_Window_Count does not exist. With SDLC, the primary_repoll_time_out parm setting must allow enough time for the largest frame to travel to and from the secondary station. Otherwise, unnecessary polls will flood the link, eventually bringing it down.
If the link speed is X bits per second and the largest frame is Y bits, then the primary_repoll_time-out should be larger than 2(Y/X).
To change this value, use the following fastpath command.
smit devicesThen follow these steps:
Select the type of communication from the list displayed (for example, TOKEN RING ADAPTER).
For systems with less than 512Mb of real memory, the value recommended for paging space is TWO TIMES the amount of real memory. For systems with 512Mb of real memory or greater, the recommended value for paging space is an amount at least EQUAL to the amount of real memory.
To display the amount of memory, enter
lsattr -El sys0 | grep realmemTo display total paging space and the approximate amount used, enter
lsps -sIt is advisable to keep the paging space used below 75% to ensure that SNA resources will be available. If these resources must be "paged" out of real memory, it is important that enough space is available to prevent SNA from experiencing errors that could result in total failure of SNA communications. If the percent used is over 75%, additional paging space should be added.
NOTE: To find the I-field size, use the following command while the link station is active.
sna -d l -o long |grep -p linkstation_nameLook for the field labeled Max frame data (BTU) size. This I-field size is controlled from within the SNA DLC profile in the SNA configuration. The I-field size should be system defined or matched exactly with the other node configuration.
When writing file transfer applications, use large buffers in the TP code. A 16K buffer size will speed up the transfer.
[ Doc Ref: 9064778089346 Publish Date: Jan. 03, 2001 4FAX Ref: 9777 ]