This document specifies the supported method for mirroring the rootvg volume group to provide high availability access of the AIX operating system. Because the rootvg contains the AIX operating system, several restrictions exist for this configuration that do not exist for the non-rootvg volume group mirroring. Therefore:
instfix -i -k IX56564
Consult the table at the end of this document to determine if the level of AIX you are running already contains this fix.
State (a) will always be a possibility. If the user prefers to prevent the risk of encountering state (c), then the user must create a non-mirrored logical volume (that is not hd6) and set the dump device to this non-mirrored logical volume. Refer to the section "Paging and dump devices" in this document for further details.
lslv -m hd5
bootinfo -B hdiskX
If the command returns a 1 then it will be bootable by AIX. Any other value indicates that this disk is not a candidate for rootvg mirroring.
When replacing a mirrored volume group, the steps are identical (with the exception of Restriction 10) for rootvg and non-rootvg volume groups:
migratepv reorgvg reducevg
and the logical volume that constitutes the dump device (typically hd6) OR its mirror resides on the disk, the user must first set the dump device to /dev/sysdumpnull before executing the command.
After the command is complete, the user may reset the dump device to the original dump logical volume.
To determine if either fix is installed on a machine, execute the following:
instfix -i -k <apar number>
The equivalent AIX 4.2 APAR fixes are listed in the table at the end of this document.
instfix -i -k <apar number>
In AIX 4.2.1, two new LVM commands were introduced: mirrorvg and unmirrorvg. These two commands where introduced to simplify mirroring or unmirroring of the entire contents of a volume group. The commands detect if the entity to be mirrored or unmirrored is rootvg, and will give slightly different completion messages based on the type of volume group.
NOTE: The mirrorvg command does the equivalent of steps 2-4 in the "Procedure" section.
When the paging device is mirrored, there will be extra write cycles as the mirrored image of the paged memory is written to disk. This will affect the performance to a slight degree. The user can choose not to mirror the paging device, but this would defeat the original purpose of rootvg mirroring, which is to keep a system or program active if a disk were to fail. If the paging device were not mirrored but all the other logical volumes in rootvg were mirrored, then the behavior of the system would be equal to that of a non-mirrored rootvg that experiences a paging disk fail in the middle of operation.
As discussed previously, when a system dump is occurring, the dump image is not written to disk in mirrored form. The logic behind this fact is that if the mirroring code itself were the cause of the system crash, then trusting the same code to handle the mirrored write would be pointless. Thus, mirroring a dump device is a waste of resources and is not recommended.
There is an alternative. In AIX 4.2.1, the secondary dump device was fixed. If a valid secondary dump device exists and the primary dump device cannot be reached, the secondary dump device will accept the dump information intended for the primary dump device.
In AIX 4.1 and subsequent releases, the dump device and the paging device are installed as the same initial device, hd6. However, in rootvg mirroring the desired behavior is to have paging mirrored, but not the dump device. Therefore, the user should create a non-paging dump device and NOT have that dump device mirrored.
The mirrorvg command takes this into account. If the dump devices are also the paging device, the logical volume will be mirrored. If the dump devices are NOT the paging device, that dump logical volume will not be mirrored.
The following steps assume the user has rootvg contained on hdisk0 and is attempting to mirror the rootvg to a new disk: hdisk1.
extendvg rootvg hdisk1
The user may encounter the following error message:
0516-050 Not enough descriptor space left in this volume group. Either try adding a smaller PV or use another volume group.
In this case, the user may not add hdisk1 to rootvg for mirroring. The user may attempt to mirror rootvg's logical volumes to another disk that already exists in rootvg and meets the criteria and restrictions listed in the "Restrictions" section above. Or, the user may attempt to add a smaller disk to the rootvg. If neither option is possible, then mirroring rootvg cannot be performed on this system.
chvg -Qn rootvg
mklvcopy hd1 2 hdisk1 # /home file system mklvcopy hd2 2 hdisk1 # /usr file system mklvcopy hd3 2 hdisk1 # /tmp file system mklvcopy hd4 2 hdisk1 # / (root) file system mklvcopy hd5 2 hdisk1 # blv, boot logical volume mklvcopy hd6 2 hdisk1 # paging space
If users have other paging devices, rootvg and non-rootvg, it is recommended that they also mirror those logical volumes in addition to hd6. Refer to the section "Paging and dump devices".
mklvcopy hd8 2 hdisk1 # file system log mklvcopy hd9var 2 hdisk1 # /var file system
If hd5 consists of more than one logical partition, then, after mirroring hd5, the user must verify that the mirrored copy of hd5 resides on contiguous physical partitions. This can be verified with the following command:
lslv -m hd5
If the mirrored hd5 partitions are not contiguous, the user must delete the mirror copy of hd5 (on hdisk1) and rerun the mklvcopy for hd5, using the -m option. The user should consult documentation on the usage of the -m option for mklvcopy.
syncvg -v rootvg
bosboot -a -d /dev/hdisk?
hdisk? is the first hdisk listed under the PV heading after the command lslv -l hd5 has executed.
bootlist -m normal hdisk0 hdisk1
WARNING: Even though this command identifies the list of possible boot disks, it does not guarantee that the system will boot from the alternate disk in all cases involving failures of the first disk. In such situations, it may be necessary for the user to boot from the installation or maintenance media: select maintenance, reissue the bootlist command leaving out the failing disk, and then reboot. On some models, firmware provides a utility for selecting the boot device at boot time. This may also be used to force the system to boot from the alternate disk.
shutdown -Fr
This is so that the Quorum OFF functionality takes effect.
Description UP & MP APAR Level ------------------------------------------------------------- mksysb fix ix56564 4.1 ------ In 4.2.0 code 4.2 ------ In 4.3.0 code 4.3 ------------------------------------------------------------- bosboot failure ix61186 4.1 ------ ix62417 4.2 ------ In 4.3.0 code 4.3 ------------------------------------------------------------- dump device patch not needed 4.1 ------ ix68483 4.2 ------ In 4.3.0 code 4.3 -------------------------------------------------------------- latest device driver mirroring fixes ix60521 4.1 ------ ix70884 4.2 ------ In 4.3.0 code 4.3 --------------------------------------------------------------- latest mirrorvg/unmirrorvg fixes not needed 4.1 ------ ix72058 4.2 ------ ix72550 4.3 ---------------------------------------------------------------
NOTE: The preceding fixes are packaged for the clvm prpq under the cumulative APAR IX58707, except for the bosboot APARs. The clvm prpq fileset ONLY exists on AIX 4.1 systems. To determine if you have the clvm prpq installed, execute the following:
lslpp -h prpq.clvm
If prpq.clvm is not installed on your system, you do not need to order IX58707.
NOTE: Please check the Internet at http://www-1.ibm.com/servers/support/ for the latest fixes.[ Doc Ref: 90605212214784 Publish Date: Oct. 19, 2000 4FAX Ref: 4254 ]