WARNING: This procedure is valid ONLY with a mksysb image and will not work with a Sysback 6000 system backup.
mkszfile
cd / vi image.data
To view and edit the file, enter:
vi image.dataExample 1
lv_data: VOLUME_GROUP= rootvg LV_SOURCE_DISK_LIST= hdisk0 LV_IDENTIFIER= 00000001113f3c62.5 LOGICAL_VOLUME= hd2 VG_STAT= active/complete TYPE= jfs MAX_LPS= 512 --> COPIES = 2 LPs = 70 STALE_PPs= 0 INTER_POLICY= minimum INTRA_POLICY= center MOUNT_POINT= /usr MIRROR_WRITE_CONSISTENCY= on LV_SEPARATE_PV= yes PERMISSION= read/write LV_STATE= opened/syncd WRITE_VERIFY= off PP_SIZE= 4 SCHED_POLICY= parallel --> PP = 140 BB_POLICY= relocatable RELOCATABLE= yes UPPER_BOUND= 32 LABEL= /usr MAPFILE= LV_MIN_LPS= 68
Example 2
lv_data: VOLUME_GROUP= rootvg LV_SOURCE_DISK_LIST= hdisk0 LV_IDENTIFIER= 00000001113f3c62.5 LOGICAL_VOLUME= hd2 VG_STAT= active/complete TYPE= jfs MAX_LPS= 512 --> COPIES = 1 LPs = 70 STALE_PPs= 0 INTER_POLICY= minimum INTRA_POLICY= center MOUNT_POINT= /usr MIRROR_WRITE_CONSISTENCY= on LV_SEPARATE_PV= yes PERMISSION= read/write LV_STATE= opened/syncd WRITE_VERIFY= off PP_SIZE= 4 SCHED_POLICY= parallel --> PP = 70 BB_POLICY= relocatable RELOCATABLE= yes UPPER_BOUND= 32 LABEL= /usr MAPFILE= LV_MIN_LPS= 68
In Example 2 the COPIES value has been changed to 1 and the PP value is set equal to the LPs value. Make these changes to each of the lv_data stanzas in the image.data file. Once the changes are made, save the file and exit.
WARNINGS:
If another mksysb cannot be run, the following procedure can be used to restore a mksysb without mirroring.
NOTE: Access to another AIX system and an AIX formatted diskette is required to perform this procedure.
All references to the tape device in the next section are as rmt0.
chdev -l rmt0 -a block_size=512
mkdir /tmp/newdata
cd /tmp/newdata
tctl -f /dev/rmt0 rewind
restore -s2 -xqvf /dev/rmt0.1 ./image.data
To view and edit the file, enter:
vi image.dataExample 3
lv_data: VOLUME_GROUP= rootvg LV_SOURCE_DISK_LIST= hdisk0 LV_IDENTIFIER= 00000001113f3c62.5 LOGICAL_VOLUME= hd4 VG_STAT= active/complete TYPE= jfs MAX_LPS= 512 --> COPIES = 2 LPs = 120 STALE_PPs= 0 INTER_POLICY= minimum INTRA_POLICY= center MOUNT_POINT= / MIRROR_WRITE_CONSISTENCY= on LV_SEPARATE_PV= yes PERMISSION= read/write LV_STATE= opened/syncd WRITE_VERIFY= off PP_SIZE= 4 SCHED_POLICY= parallel --> PP = 240 BB_POLICY= relocatable RELOCATABLE= yes UPPER_BOUND= 32 LABEL= / MAPFILE= LV_MIN_LPS= 68
Example 4
lv_data: VOLUME_GROUP= rootvg LV_SOURCE_DISK_LIST= hdisk0 LV_IDENTIFIER= 00000001113f3c62.5 LOGICAL_VOLUME= hd4 VG_STAT= active/complete TYPE= jfs MAX_LPS= 512 --> COPIES = 1 LPs = 120 STALE_PPs= 0 INTER_POLICY= minimum INTRA_POLICY= center MOUNT_POINT= / MIRROR_WRITE_CONSISTENCY= on LV_SEPARATE_PV= yes PERMISSION= read/write LV_STATE= opened/syncd WRITE_VERIFY= off PP_SIZE= 4 SCHED_POLICY= parallel --> PP = 120 BB_POLICY= relocatable RELOCATABLE= yes UPPER_BOUND= 32 LABEL= / MAPFILE= LV_MIN_LPS= 120
In Example 4 the COPIES value has been changed to 1 and the PP value is set equal to the LPs value. Make these changes to each of the lv_data stanzas in the image.data file. Once the changes are made, save the file and exit.
echo data > signature
format /dev/rfd0
find . -print |backup -iqvf /dev/rfd0
restore -Tqvf /dev/rfd0
[ Doc Ref: 90605188214722 Publish Date: Oct. 02, 2000 4FAX Ref: 2156 ]