gs -sDEVICE=jpeg -r300x300 -sOutputFile=pet01.jpeg pet01.eps GS> quitwill create a JPEG file pet01.jpeg. The -r flag controls the resolution. Alternatively:
gs -sDEVICE=jpeg -r300x300 -sOutputFile=pet01.jpeg pet01.eps -c showpage GS> quitSometimes this helps:
gs -sDEVICE=jpeg -sPAPERSIZE=a4 -r300x300 -sOutputFile=pet01.jpeg pet01.eps -c showpage GS> quit
gs -sDEVICE=tiffg3 -r300x300 -sOutputFile=pet01.tiff pet01.eps GS> quitwill create a TIFF file pet01.tiff. The -r flag controls the resolution. Alternatively:
gs -sDEVICE=tiffg3 -r300x300 -sOutputFile=pet01.tiff pet01.eps -c showpage GS> quitSometimes this helps:
gs -sDEVICE=tiffg3 -sPAPERSIZE=a4 -r300x300 -sOutputFile=pet01.tiff pet01.eps -c showpage GS> quit
gs -sDEVICE=tiffg3 -g1024x768 -r100x100 -sOutputFile=survival.tiff survival.eps GS> quitwill create a TIFF file survival.tiff. The -r flag controls the resolution.
xview survival.tiffto load and save the picture as X11 bitmap.
acs.ps
.
Apparently it should contain a showpage
instruction. Then:
gs -sDEVICE=pdfwrite -sOutputFile=acs.pdf acs.ps -c showpage GS> quitwill create a PDF file
acs.pdf
.
acroread publication.pdf
xwd -out /tmp/page.xwd
xv
utility to convert the pixel data
into an X11 bitmap file:
xv /tmp/page.xwdYou may use the "Grab" function to cut off unwanted junk around the figure. Then store the image as "X11 bitmap", e.g. as
figure1.xbm
gd
progam to pickup the data points:
gdthen, at the command prompt
gimage figure1.xbm gd / nospace xmin(...) xmax(...) ymin(...) ymax(...) noaxisa cursor rectangle will appear which lets you define the x- and y-axis on the figure. You will have to specify the axis limits. Use
xlog
, ylog
where appropriate.
gpos /loop gsave figure1.gd
An example for use with the old LaTeX system (which should no longer be used, however) can be found in oldposter.tex The example has 9 boxes 8.5cm each realized by minipages, distance 1 cm.
A more recent example using colours and included pictures can be found here and how the result looks like there
Here are the three steps:
\textwidth 30.0cm \textheight 40.0cmdefine an A3 page. On the UNIX command line
latex poster ; dvips -t a3 poster; gv poster.ps -magstep -3 &processes your LaTeX source file and displays it on screen (
-magstep -3
allows to view the whole poster).
\textwidth 30.0cm \textheight 40.0cmFor printing you need extra
\voffset -3cm \hoffset -2cmotherwise the printout would be shifted towards the lower right corner and hence doesn't fit on the A3 media anymore. For printing you obviously need on A3-capable printer. At GSI you might query those guys by:
man printer | grep lpswhich currently ( 28-Jun-1999 ) yields
p16 wps,lps,wpd,gps,gpd RZ Maschinensaal p28 wps,lps Grossmontage Lager p30 wps,lps UHV Jacoby 3.004 p50 lps Mittelspange Nordbau p54 lps Pauserei 2.210 p66 wps,wpd,lps EE-Labor p77 lps,wps Be.-Labor 2.118 p78 lps,wps Be.-Labor 2.116where according to GSI convention
'lps'
stands for
"White paper, ascii/postscript, DIN A3, single sided"
.
latex poster ; dvips -t a3 poster; lpr -Pp16lps poster.ps &or, alternatively
latex poster ; dvips -t a3 poster; pop -p16lps poster.ps &
%\voffset -3cm %\hoffset -2cmFor processing and creating a print-ready PostScript file (poster.ps) you use the UNIX line command
latex poster.tex ; dvips -t a0 -x2650 posterThe "-t a0" is necessary to define the bounding box of the poster. If omitted it would be cut off at DIN A4 size. The "-x 2650" defines magnification by 1000.
pop -p51 -l 1200 poster.psto print on the specified printer (p51pcs) with a paperlength of 1200 mm
mread <dosfile> <unixfile>
mread -n <dosfile> <unixfile>
mread -t <dosfile> <unixfile>
mwrite <unixfile> <dosfile>
mwrite -n <unixfile> <dosfile>
mwrite -t <unixfile> <dosfile>
tr <inputfile >outputfile -d '\r'Input and output file must be different !!!
word.doc
, then
on any biori6*-Machine, central AIX-machine or central Linux-Machine:
word2txt wordwill convert the
word.doc
into a readable ASCII
file word.txt
.
Note, however, that word.doc
must reside in your home file
system (which is the normal case).
ldat ms.doc
lhalw ms.doc --to_stdout
lhalw ms.doccreates a plain ASCII file ms.txt.
export LANG=Cmight help.
axbe patient and the Applix Menu will pop up.
antiword
freeware antiword msword.doc > ascii.txt
axbe patient and the Applix Menu will pop up.
dsmc archive -subdir=yes -archsyml=no -archmc=totape "ftp.software.ibm.com/*"will archive the specified directory (and all its subdirectories) onto tape media, symbolic links will be store as such, i.e. not as files.
virtualnodename
parameter.
biops5z
:
dsmc restore -replace=yes -inactive -virtualnodename=biops5z /userfs/userb01/feinbein/.profile /u/feinbein/.profileYou will be prompted for ID and password, both are equal to the node name.
biops5z
and use
dsmc restore -replace=yes -inactive /userfs/userb01/feinbein/.profileto restore without prompt.
rootvg
dsmc restore -subdir=yes -ifnewer "/opt/" dsmc restore -subdir=yes -ifnewer "/var/" dsmc restore -subdir=yes -ifnewer "/"
biori6h
's
/
and /var
directory to a temporary location:
dsmc restore -subdir=yes -virtualnodename=biori6h "/" "/s/bio/biori6h/" dsmc restore -subdir=yes -virtualnodename=biori6h "/var/" "/s/bio/biori6h/"You will be prompted for ID and password, both are equal to the node name.
rlogin aix.poolor
telnet aix.pool
rlogin aix.poolor
telnet aix.pool
dsmc restore -pick -inactive /userfs/userb01/feinbein/.profile
clri6m
:
dsmc q backup -subdir=yes -inactive "/userfs/userb01/gunzert/Anna/Gamma-Spektoskopie/OKT05/Gauss-Fit-Datenblaetter/*"On other machines you need a password and:
dsmc q backup -subdir=yes -inactive -virtualnodename=clri6b "/userfs/userb01/gunzert/Anna/Gamma-Spektoskopie/OKT05/Gauss-Fit-Datenblaetter/*"
find ./ ! -name "*,v" -exec \rm {} \;removes all files not ending with
,v
from the current directory
and all directories below. Directories themselves are not deleted.
tar -cvf - dir1 dir2 | rsh biori6z dd of=/dev/rmt0archives directories
dir1
and dir2
to tape /dev/rmt0
at machine biori6z
loopmount -i /d/bioimages/texlive2011-20110705.iso -o "-V cdrfs -o ro" -m /cdrommounts the specified ISO file as if it were a CD/DVD ROM.
root
privileges.
mkisofs [-U] -o <outputfile> <inputpath>Example(s):
mkisofs -U -o test.iso phd mkisofs -D -U -rock -iso-level 3 -o test.iso phd # ignore directory nesting limit, allow symlinksgenerates an ISO image
test.iso
comprising all files in directory
phd
. The image test.iso
is ready
to be transferred to CD with cdrecord
.
-U
option causes filenames to be left unchanged,
which violates the ISO norm, but is better suited for UNIX filenames.
cdrecord dev=1,0 image.iso # for CDs readcd -w dev=1,0 f=image.iso # for DVDsburns the (disk-resident) ISO image file
image.iso
on CD/DVD writer
/dev/cd1
More hints (CD recording seems to be heavy magic):
sometimes the message appears: "readcd: Invalid argument. Cannot send SCSI cmd via ioctl" This can be ignored, just re-issue the command.
Depending on host hardware, cdrecord
version and type
of CD writer, explicitly specifying writing speed might help:
cdrecord ... speed=4 ...
rsync -v -r -l -S -p -o -g -t -u [-n] [--delete] /mnt/$user/ /userfs/userb01/ rsync -e ssh -v -r -l -S -p -o -g -t -u [-n] [--delete] /mnt/$user/ user@node:/userfs/userb01/copies all newer files from
/mnt/$user
to /userfs/userb01/$user
,
preserving permissions, ownerships and times.
ssh
services to copy to a remote node
(and will prompt a password)
-n
selects a (recommended) "dry run" without actually
doing something.
--delete
deletes all files in the target directory(ies) which
do not exist in the source directory. Use it with care !
smitty
Problem Determination - Hardware diagnostics - Current Shell Diagnostics - Resource SelectionSelect the disk to format (take care !), use
F7
to commit.
Task Selection
choose Format Media
, then
Format and certify disk
. Think twice and go ahead.
Be patient, it may take an hour or so.
restore -T -f /dev/rmt0
dd if=/dev/rmt0 ibs=512 of=/tmp/rmt0.dd dd if=/dev/rmt0 ibs=10240 of=/tmp/rmt0.dd # alternative ?
installp -l -d /dev/rmt0 >/tmp/rmt0.log 2>&1
tctl -f /dev/rmt0 rewind # position at tape start tctl -f /dev/rmt0.1 fsf 3 # skip first 3 files, don't rewind tar -tvf /dev/rmt0.1 >/tmp/rmt0.log 2>&1 # here we are
tctl -f /dev/rmt0 rewind restore -s4 -Tvqf /dev/rmt0.1 >/tmp/rmt0.log 2>&1
/dev/rmt0
into file /tmp/rmt0.log
.
fs
, and associated
logical volume (LV), /dev/lv
,
to be moved to another VG, newvg
.
mklv -y newlv newvg number_of_physical_partitionsIn any case:
chlv -t copy newlv # flags that it will receive a copy
mklv -t jfslog newvg 1 # for a jfs LV mklv -t jfs2log newvg 1 # for a jfs2 LV logform /dev/loglv00 # assuming this is the JFS log, insert the actual name here
exportfs -u fs umount fsIf, as usual, this can't be accomplished because somebody is using the filesystem, use
fuser /dev/lv # or: lsofto discover and
kill -9
the offending processes.
fuser -kxuc /dev/lvkills everything associated with
/dev/lv
cplv -e newlv -f lv # copy old to new LV, may take looong, so be patient! chlv -n oldlv lv # swap LV names ... chlv -n lv newlv # swap LV names ...
chfs -a dev=/dev/lv fs # the new LV it resides on chfs -a log=/dev/loglv00 fs # the new JFS log it uses, use the actual JFS log name here !!!
fs
.
exportfs fs
.
It might be necessary to un/remount on the client side:
umount -f client_mountpoint_for_fs
smitty
to
remove old LV oldlv
.
/fsnew
on the target file server,
as described here, but delay NFS access
until later.
# for a dry run rsync -e ssh -v -r -l -S -p -o -g -t -u -n /fsold/ root@target:/fsnew # for real rsync -e ssh -v -r -l -S -p -o -g -t -u /fsold/ root@target:/fsnewmind the trailing slash (
/
), it's significant!!
cp -h -r -p /fsold/ /fsnew/One may verify the successful transfer by comparing filesystem sizes:
du -g -s /fsold/ du -g -s /fsnew/however, this is only a crude estimate since some filesystem types offer compression. Alternatively, the number of files in both filesystems can be compared via
find /fsold/ |wc find /fsnew/ |wcwhere the first two numbers (lines, words) should be approximately equal.
smitty Communications Applications and Services - NFS - Remove a Directory from Exports List # command line: /usr/sbin/rmnfsexp -d '/fsold' '-B'
smitty System Storage Management - File Systems - Unmount a File System # command line: /usr/sbin/umount /fsold
smitty System Storage Management - File Systems - Delete File Systems - [Enhanced] Journaled File Systems - Remove a[n Enhanced] Journaled File System # command line: /usr/sbin/rmfs /fsold
/usr/tivoli/tsm/client/ba/bin/dsm.opt
dtterm
window titleecho "\033]1;my_title\007" # changes the icon title echo "\033]2;my_title\007" # changes the window title echo "\033]0;my_title\007" # changes bothor, simpler, with a special of command of our own:
wt my_title
xmodmap -e 'pointer = 3 2 1'will swap the left and right mouse button
xmodmap -e 'pointer = default'reverts to the old state.
/usr/lpp/X11/defaults/xmodmap/en_US/keyboard
keycode 50 = backslash bar NoSymbol !keycode 50 = NoSymbol NoSymbol NoSymbolthen run
xmodmap /usr/lpp/X11/defaults/xmodmap/en_US/keyboard
# mirror a site in background: nohup wget -m -e robots=off http://www.huge.site/ & # mirror a site, don't go up in tree, exclude a directories wget -m -e robots=off --no-parent --exclude-directories=notthis http://www.huge.site/
<ftp-site>
with a required account <account>
with password <passwd>
.
Then
wget -r -e robots=off --user=<account> --password=<passwd> ftp://<account>@<ftp-site>will let you access the files as usual.
/etc/inetd.conf
ftp stream tcp nowait root /usr/sbin/ftpd ftpd -t 1800After refresh of the
inetd
subsystem the timeout will be 1800 seconds.
Refreshing is accomplished by the line command
refresh -s inetdor by the
smitty - Processes & Subsystems - Subsystems - Refresh a Subsystem
menu selection.
site idle 1800will do the job. The currently valid timeout can be queried by the ftp subcommand
site idle
printq
-privileges which are currently available
for the accounts bio
and stephan
.
You use the smit
tool on the command line:
smittythen walk through the menus
Print Spooling - Manage Print Queues - Start a Print QueueFill in the required information and press enter.
/usr/lpp/UMS/defaults/mime/setup_ums_mime
oslevel -rto determine current OS maintenance level. If not as expected sth like
instfix -ciqk 5200-09_AIX_ML | grep ":-:" | pgmight tell you which filesets are missing to reach e.g. AIX 5.2 ML-09
bootinfo -y
tells the 32/64-bit capability of the system.
bootinfo -K
tells the 32/64-bittedness of the currently
active kernel.
ln -fs /usr/lib/boot/unix_64 /usr/lib/boot/unix ln -fs /usr/lib/boot/unix_64 /unixFrom 64 to 32 bit:
ln -fs /usr/lib/boot/unix_up /usr/lib/boot/unix # for uni-processor machines ln -fs /usr/lib/boot/unix_up /unix ln -fs /usr/lib/boot/unix_mp /usr/lib/boot/unix # for multi-processor machines ln -fs /usr/lib/boot/unix_mp /unixThen in both cases:
bosboot -a -l /dev/hd5 -d /dev/hdisk0 bosboot -a -l /dev/hd5 -d /dev/hdisk1 # for a mirrored disk bootlist -m normal hdisk0 hdisk1 # paranoia bootlist -m normal -o # paranoia shutdown -Fr
chdisp -d bbl0 # temporarily switch to graphics adapter "bbl0" chdisp -p bbl0 # permanently switch to graphics adapter "bbl0"Needs reboot / X11 restart.
lsattr -El proc0should give CPU architecture and clock frequency (in Hz) for CPU
proc0
smitty
, then Software Installation/Maintenance
,
or on the command line e.g.:
/usr/lib/instl/sm_inst list_filesets -l -f _all_available -d '/dev/cd0' >/tmp/content.txt 2>&1will list the software on CD/DVD in drive
/dev/cd0
into file /tmp/content.log
.
For multi-volume sets it is sufficient to list the first CD/DVD of the set.
root
rights.
smitty
, then System Storage Management - System Backup Manager
,
or on the command line e.g.:
/usr/sbin/restore -s 4 -Tqv -f /dev/rmt0.1; tctl -f /dev/rmt0.1 rewindThis command sequence skips the first four tape files (
-s 4 -q
)
and positions the tape at the fifth, which is the real backup.
The files in the backup are then listed (-Tv
).
The tape special file has to be "non-rewinding" (/dev/rmt?.1
)
to avoid rewinding after one of the first four EOF's.
Finally, tctl
repositions the tape at its load point.
root
rights.
vers=2
wherever applicable:
mount -o vers=2 ... # when mounting manually
nfs_mount: 109 error while mounting (.....): Function not implementedCure:
ypbind
must be started, then:
stopsrc -s automountd stopsrc -g nfs /etc/rc.nfs # should start ypbind services
amd
considers them still as
being mounted.
cd /local/etc/amd # assuming this is where amd is installed amd_umount amd_stop amd_start
From: MAILER-DAEMON@biori6m.gsi.de (Mail Delivery Subsystem) Subject: Returned mail: Cannot send message for 3 days To:the permissions in the mail folder (--- The transcript of the session follows --- bellmail: lockf(/usr/spool/mail/kehr): The file access permissions do not allow the specified action.
/var/spool/mail/*
) are not correct.
chmod g+w /var/spool/mail/*
application/postscript /usr/local/bin/ghostview -safer %sif not, choose "New" or "Edit" and insert this line
/etc/profile
must exist and
should contain the lines
if [ -x /local/bin/profile ] then . /local/bin/profile fiwhere
/local/bin/profile
is a system-wide profile copied from
GSI's central AIX cluster.
Both files must be world-executable (chmod a+x).
/bioapps/APPLIXE/axlocal/axlicensedat
some daemons have to be killed and restarted. Login biori6b
as root,
get the respective process IDs with:
ps uag | grep BIOAPPS ps uag | asterxdand kill the processes in that order (!). Then restart
/bioapps/APPLIXE/axdata/axnlmgrd -c /bioapps/APPLIXE/axlocal/axlicensedat >/tmp/axnlmlog &
xxx
=BIO_NIS
)other boot devices
. Select the CD-ROM drive, insert the
CD and boot.
vi /etc/rc.nfsand disable ypbind. Depending on the nature of the trouble it may be necessary to disable other components to.
vi
export TERM=lft
smittyand choose communications-TCP/IP-mimimum configuration.
/etc/rc.nfs
$HOME/.dt/startlog
for more info.
/var
full.
rm /var/adm/wtmp
getrootfs hdisk0 ksh; export TERM=lft # try, if "vi" is to be used # if unsuccessful, "vi" runs in "open" mode, # i.e. use "l" and "h" to navigate right and left, respectively # # ... actions to be done to fix the problem # sync; sync; sync # force writing changes to disk shutdown -Fr # or: reboot
vi /etc/security/passwordand remove the root password.
vi /etc/inittaband outcomment (place a colon,
:
, before the line)
the offending line which invokes /etc/rc.nfs
.
sshd
daemon might not be active or not even installed,
telnet
services might be disabled via inetd.conf
etc.
/etc/hosts.deny
, /etc/hosts.allow
,
which by default reject any access.
nedit
refuses cut&paste, etc
root
:
cd /usr/bin/X11 cp -p X X.save # save original X cp -p X X.large # the new X # tell the executable to use 1GB heap space /usr/bin/echo '\0100\0\0\0' | dd of=X.large bs=4 count=1 seek=19 conv=notrunc ln -sf X.large X
hdisk5
)
is dead.
smitty - System Storage Management - Logical Volume Manager - Volume Groups - Unmirror a Volume Group PHYSICAL VOLUME names [hdisk5] # specify dead disk +
smitty - System Storage Management - Logical Volume Manager - Volume Groups - Set Characteristics of a Volume Group - Remove a Physical Volume from a Volume Group * PHYSICAL VOLUME names [hdisk5] +
smitty - Devices - Fixed Disk - Remove a Disk Disk hdisk5 KEEP definition in database no +then remove it physically from the machine.
smitty - Devices - Install/Configure Devices Added After IPL
hdisk5
.
smitty - System Storage Management - Logical Volume Manager - Volume Groups - Set Characteristics of a Volume Group - Add a Physical Volume to a Volume Group * PHYSICAL VOLUME names [hdisk5] +
smitty - System Storage Management - Logical Volume Manager - Volume Groups - Set Characteristics of a Volume Group - Mirror a Volume Group PHYSICAL VOLUME names [hdisk5] + Number of COPIES of each logical 2 + partition(be patient, might take several minutes)