make_tape_recovery -I -x inc_entire=vg00saves the "
rootvg
".
mkrs -v -q -tdat -f /dev/rmt/... -r /dev/dsk/... # make a bootable tape mkrs -v -q -tdat -f /dev/rmt/... -r /dev/dsk/... -m700 # make a bootable tape, force series 700 fbackup -0 -i / -f /dev/rmt/...
ISL> ODE
ODE> COPYUTIL
frecover -V /tmp/fb.volhd -N -v -f /dev/rmt/0m # read backup volume header frecover -r -N -v -f /dev/rmt/0m >/tmp/fb.log 2>&1 # lists backup frecover -r -X -v -f /dev/rmt/0m # restores backup tree into local directory frecover -x -X -i /bin+ -v -f /dev/rmt/0m # extract a specific object into local directory
SAM
or ioscan
to check if it's properly recognized. If not, check jumper settings.
mediainit /dev/rdsk/c201d1s0 /etc/diskinfo -v /dev/rdsk/c201d1s0
/etc/disktab
,
add the appropriate entries, as explained in that file.
For SCSI disks the most important one is s0#
,
the size (in kB) taken from diskinfo
.
Formally required are also ns#,nt#,nc#,
,
but in my experience they can be faked, so that their product yields s0#
.
s0#
reduced by the amount foreseen for swap and boot area (combined).
Example:QUANTUM_FIREBALL1280S_noswap|QUANTUM_FIREBALL1280S_noreserve|QU_FIREBALL1280S_noswap|QU_FIREBALL1280S_noreserve:\ :No swap or boot:ns#32:nt#16:nc#2445:\ :s0#1251840:b0#8192:f0#1024\ :se#512:rm#3600: QUANTUM_FIREBALL1280S_150MB|QU_FIREBALL1280S_150MB:\ :150 MB swap:ns#32:nt#16:nc#2145:\ :s0#1098240:b0#8192:f0#1024\ :se#512:rm#3600:
newfs -v -L /dev/rdsk/c201d1s0 QUANTUM_FIREBALL1280S_150MBYou may wish to protocol some of the listed superblock numbers, for emergency use with
fsck
.
/etc/disktab
may be bypassed by using
/etc/mkfs
, in this case some parameters (e.g. the size) have to be specified on the command line:
/etc/mkfs /dev/rdsk/c201d1s0 1098240Anyway,
/etc/mkfs
is called by /etc/newfs
IPL bad address
error will occur on boot.
mount /dev/dsk/c201d1s0 /mnt # example for SCSI ID=1 in an 9000/715 fbackup -0 -i / -e /mnt -f - | (cd /mnt; frecover -Xrf -)
mkboot -v /dev/dsk/c201d1s0and check bootability:
lifls /dev/rdsk/c201d1s0A bootable disk reports something like:
FS SWAP ISL AUTO HPUX EST ODE MAPFILE SYSLIB MAPPER IOTEST PERFVER XDIAG PADwhile a non bootable disk reports an error message.
/mnt/etc/checklistto reflect the new filesystem to be
fsck
'ed on boot.
dd if=/dev/rmt/0mn of=install.lif bs=2k # note: 0mn to suppress rewind dd if=/dev/rmt/0m of=install.tar bs=10k # note: 0m to allow rewind # insert copy tape dd if=install.lif of=/dev/rmt/0mn bs=2k # note: 0mn to suppress rewind dd if=install.tar of=/dev/rmt/0m bs=10k # note: 0m to allow rewindIf you have two tape drives:
dd if=/dev/rmt/0mn of=/dev/rmt/1mn bs=2k # note: 0mn to suppress rewind dd if=/dev/rmt/0m of=/dev/rmt/1m bs=10k # note: 0m to allow rewindSometimes such tapes have a third file, a "pseudo-tar", which serves as an extra indicator of the end-of-tape. I think it can be ignored.
dd < /dev/rmt/0m > scratchfile ibs=10240 obs=512 # source tape, mind the blocksizes ! tar tf scratchfile # verify proper tar format dd < scratchfile > /dev/rmt/0m ibs=512 obs=10240 # target tape, mind the blocksizes ! tar tf /dev/rmt/0m # verify proper tar format
After copying, an integral number of records should be reported, e.g.:
19742+0 records in 394840+0 records outOtherwise the blocksize is incorrect or the tapes are not in the HP format.
echo $(uname -r | sed -e 's/..//' -e 's/\.//')
#if defined(__hpux) #include <sys/privgrp.h> #if defined(PRIV_PSET) #define _hpux_11i #elif defined(PRIV_SPUCTL) #define __hpux_11x #define OSMAJORVERSION 11 #elif defined(PRIV_SERIALIZE) #define __hpux_10x #elif defined(PRIV_SETRUGID) #define __hpux_9x #endif #endif
cc
compiler's +DD64
option for compilation.
On 32-bit systems the 64-bitDevLibs
(Cross Platform Development Kit) must be installed to create executables.
Of course 64-bit executables can't be executed on 32-bit systems.
cc
compiler implements the 4/8/8 model
for (int/long/ptr).
cc -Aa +z ld -o libxxx.sl -b *.oForce linking against archive libraries, HP-UX 10.20:
cc cc ... -Wl,-a,archive_shared ld ... -a archive_shared ...
telnet
sessionssh
.
SAM
requires specific terminal characteristics.
One may use a VT220
emulation:
export TERM=vt220 # for ksh
mv /stand/build/System.SAM /stand/system # list of kernel parameters /usr/sbin/kmupdate shutdown -r -y now
netdist
servernetdist
server is particular convenient
to store
codeword protected software (provided one has codeword
and proper license, of course), since it can be copied
(unprotected) once and for all times from CD to a server disk.
/netdist
, possibly on an extra
disk.
MAIN.pkg
, and all paths have to be consistently named
when the server daemon is started (place softlinks if necessary).
mount -r -t cdfs /dev/dsk/c201d3s0 /UPDATE_CDROM # example for SCSI ID=3 at an 9000-715Or use SAM for that.
/etc/updist
Change Source or Destination From CD-ROM to local system Destination /netdist Codeword .... .... .... .... # from the HP license sheet, exactly as written (don't forget e.g. trailing hyphen's) ! Hardware ID ddddAnnnnn # defined via ID box, don't enter. Echoed by system. Select all FilesetsThe installer might ask for the architecture (300/700/800), only one of these can be installed in a single
updist
run.
Messages on missing target directories (300/700/800) can be ignored.
updist
has finished, the contents of the netdist
directory (300,700,800,MAIN.*
) may be transferred elsewhere.
/etc/netdistd -f /netdist/MAIN.pkg -v -c /tmpwhich says that caching should go into
/tmp
and verbose logging will go into /usr/adm/netdist.log
.
It might be necessary to allow netdistd
service
in /usr/adm/inetd.sec
and /etc/services
.
man netdistd
mount -r -t cdfs /dev/dsk/c201d3s0 /cdrom # CD-ROM @ SCSI ID=3, 9000/715 /etc/update -c -s /cdromHP-UX 10,11 example:
mount -r /dev/dsk/c2t0d0 /cdrom # swlist -s /cdrom # list with more info swlist -a tag -a revision -a path -a is_secure -a title -f /cdrom
/etc/update
, swlist
, et al.,
comes in Logical Interchange Format (LIF).
SAM - Peripheral devices - View allHP-IB devices should be listed with select code 7
dd if=/dev/dsk/c7d0s0 of=pascal.ddimgmay report
dd read error: I/O error 1544+0 records in 1544+0 records outbut this is probably just "end-of-floppy"
lifls -l /dev/dsk/c7d0s0 # list filesets on IB floppy lifcp -r /dev/dsk/c7d0s0:A98518A - | cpio -idumvx # example to extract to current directory
SAM task controller initialization failed. rc = 1402
messagetouch /usr/sam/lib/*/*.LLsolved the problem for me. See also SAM's error log,
/usr/sam/log/samlog
,
for more information.
SAM
to modify the maxuprc
parameter (e.g. to 256).
This parameter is dynamic (i.e. doesn't require reboot) on
HP-UX 11.x.
SAM - Kernel Configuration
to modify the maxdsiz
parameter (e.g. from 67108864 to 268435456, i.e. from 64 to 256MB).
This parameter is static (i.e. a kernel rebuild/reboot will follow) on
HP-UX 11.0.
nfile
.
nproc
:
(20+8*MAXUSERS)
=>
(20+16*MAXUSERS)
boot pri isl
ISL> hpux -is
passwd root
to change root passwordVUElite
,
otherwise use failsafe session or command line login.
/etc/resolv.conf
and resolution order, defined in
/etc/nsswitch.conf
, if applicable for the particular HP-UX version.
/etc/resolv.conf
and
/etc/nsswitch.conf
, if applicable for the particular HP-UX version.
* Local local /usr/bin/X11/X :0 * Local local@console /usr/bin/X11/X :0in one of the following files
/usr/lib/X11/vue/Vuelogin/Xservers
/usr/vue/config/Xservers
(template in /usr/vue/newconfig/Xservers
)
/etc/dt/config/Xservers
(template in /usr/dt/config/Xservers
)